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1. Introduction 
 

With Leica Survey Office, you will be able to manage total station and digital level survey 
data with ease and comfort through a widespread functionality offered.  
 
The Leica Survey Office software’s many features, divided into two main categories, 
include: 
 
Main Tools 
 
• Data Exchange Manager 
• Coordinate Editor 
• Codelist Manager  
• Software Upload 
 
TPS300/700 & DNA Tools 
 
• Format Manager 
• Configuration Manager  
• DNA GSI Converter 
 
Besides the above, the software also allows you to integrate program(s) of your 
preference, which will be classified under the category External Tools.  
 
This user’s manual is designed to familiarize you with the displays and features of the 
Leica Survey Office software. The functions and use of the software are also detailed on-
line, accessible from inside the software via the Help button.  
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2. Installing / Uninstalling Leica Survey Office   
 
2.1 Installation  
 

• Load the CD-ROM into the drive; the installation program starts automatically. 
• Follow the series of instructions, which the installation program will guide you 

through.  
 

Note: 
 
Should the CD-ROM not start the installation program automatically after loading, select 
Setup.exe on the CD-ROM to install Leica Survey Office. 

 
2.2 Uninstall Leica Survey Office 
 

• From the Windows Start menu, click Programs > Leica SurveyOffice > Uninstall 
Leica SurveyOffice . 

• Follow the series of instructions, which the uninstall program will guide you through. 
 
 
3. Getting Started   
 
3.1 Communication Settings 
 

Communications settings, also known as port settings can be set in the main program of 
Leica Survey Office. The options for setting communications settings are also available in 
the Data Exchange Manager, Software Upload and Configuration Manager.  
 

3.1.1 Define Communication Settings 
 

1. On the Settings menu, click Communication Settings. 
2. Under Current Selection, in the Port box, click the name of the port and in the 

Instrument box, click the instrument class, which your connected instrument belongs 
to.  

3. Under Settings, set the Baud rate , Parity, Stop bits, Data bits and End mark to 
match the communication parameters set in the instrument connected to the serial 
port. Alternatively, you can set the communications parameters for the serial port to 
the instrument class default settings by clicking Defaults.  

4. Click OK to specify.   
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The table below shows the default communications settings (bold) for the different 
instrument series and other possible combinations.  

 
 Baudrate  Parity Stop bits Data bits End mark 
TC600/800 Series 9600 

4800 
2400 
... 

EVEN 
 

1 7 <CRLF> 
<CR> 

TPS300/700 Series  19200 
9600 
4800 
2400 
... 

NONE 
EVEN 

 

1 8 
7 

<CRLF> 
<CR> 

TPS1000 Series  9600 
4800 
2400 

19200 
... 

NONE 1 8 <CRLF> 
<CR> 

TPS1100 Series  19200 
4800 
2400 
9600 
... 

NONE 1 8 <CRLF> 
<CR> 

DNA  19200 
9600 
4800 
2400 
... 

NONE 
EVEN 

 

1 8 
7 

<CRLF> 
<CR> 

 
Note: 

 
• Ensure that the communications settings for the selected serial port match the 

communications parameters set in the connected instrument.  
• The same communications settings defined in one application, for example, the Data 

Exchange Manager, imply to all others in Leica Survey Office.  
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3.2 External tools 
 

Leica Survey Office allows you to integrate one or more programs, which are classified 
as external tools after being registered in the main program.  
 

3.2.1 Customization 
 

• On the Settings menu, click Customize. 
  

In the Customize dialog box, all registered programs are displayed in the Menu 
Contents box.  

 
Other options available in the Customize dialog box are as follows:  

 
Add  
To register a program.  

 
Remove  
To remove a selected external tool.  

 
Move Up  
To focus the external tool immediately above where you are at currently in the Menu 
Contents box.  

 
Move Down  
To focus the external tool immediately below where you are at currently in the Menu 
Contents box.  

 
Menu Text  
The Menu Text box consists the name of an external tool.  

 
Command 
 
You can select the program you want to register by clicking  on the right of the 
Command box.  

 
Arguments  
You can type arguments (optional) for an external tool.   

  
 Initial Directory 

You can select the initial directory of an application by clicking  on the right of the 
Initial Directory box.  

 
• Click OK to register/save or Cancel to abort function.  
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3.3 Data Exchange Manager 
 

Data Exchange Manager enables you to exchange data (for example, Coordinate files, 
Codelists, Format files, Configuration files) between a connected instrument (either 
through its internal memory or a memory card, inserted in the instrument or an external 
drive) and the PC.  
 
The program window, as shown below, consists of two tree-views: 

 

 
 

The tree-view on the left shows the instrument type connected to the selected serial port, 
its contents (internally or a memory card) such as folders and files. The right tree-view 
displays PC drives, folders and files. You can filter files located on the PC tree -view. Data 
can also easily be uploaded to a connected instrument or downloaded to the PC.      
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3.3.1 Transfer file(s) to the instrument/PC 
 
You can transfer file(s) from the PC to a connected instrument (internal memory or 
memory card) or vice versa  
 
Depending on the instrument class the connected instrument belongs to, you can upload 
the following files:  
 

 Coordinate 
files 

Codelists Format files Others 

TC600/800 Series X X  X  N/A 
TPS300/700 Series X  X  X  N/A 
TPS1000 Series X  N/A N/A X  
TPS1100 Series X  X  N/A X  
DNA X  X  X  N/A 

 

 
Depending on the instrument class the connected instrum ent belongs to, you can 
download the following files:  
 

 Coordinate 
files  

Codelists  Measure-
ment files  

Result files Others 

TC600/800 Series  X  X  X  N/A N/A 
TPS300/700 Series  X  X  X  N/A N/A 
TPS1000 Series  X  N/A X  X  X  
TPS1100 Series  X  X  X  X  X  
DNA  X  X  X  N/A N/A 
 

 Note: 
 

• Right clicking over either tree-view will bring you to more functions, which you can 
perform in Data Exchange Manager.  

 
 
3.4 Coordinate Editor 
 

Coordinate Editor enables you to create and save coordinate lists containing Point Id, 
Easting, Northing, Elevation, Code and Attributes that will work on Leica instruments. You 
can select from the different file types of coordinate lists, namely IDEX, GSI-8/16 and 
ASCII files. Importing data from any structured ASCII file is made easy by using the File 
Import Wizard.   
 
In the Coordinate Edit View, all data contained in a coordinate file are presented in a list. 
Each row represents a point with specific coordinate values and may include a Code and 
a maximum of eight Attributes. Various editing functions can be carried out in the 
Coordinate Edit View.   

 
 Useful Tip:  
 

The coordinate spreadsheet behaves similar to the Microsoft Excel spreadsheet.  
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3.4.1 Create a new coordinate list 
 

1. On the File menu, click New to see a window displaying a blank spreadsheet. 
2. You can then enter your data in the appropriate columns, which consist of Point Id, 

Easting, Northing, Elevation, Code and Attributes 1 – 8.  
 
3.4.2 Open a coordinate file  
 

1. On the File menu, click Open.  
2. In the Files of type  box, click the type (IDEX, GSI or All Files) of the file you want to 

open. If All Files is clicked, a template can be selected in the Template  box.  
3. In the Look in box, click the drive or folder that contains the coordinate file. 
4. In the list box, click the coordinate file you want to open.  
5. Click OK to open. 
 
Note:  
 
IDEX or GSI files, when selected will be opened and displayed immediately in the 
coordinate Edit View 
When an ASCII file is selected, the File Import Wizard will be called if <none> is clicked 
in the Template box of the Open File dialog box. The ASCII file will be opened and 
displayed if a defined template is selected.   

 
 
3.4.3 ASCII File Import Wizard  
 

The ASCII File Import Wizard enables you to import ASCII files to the Coordinate Editor. 
All information about one specific point must be contained within a line. The items may be 
separated by a specific character or positioned in columns of fixed width separated by 
spaces.  
 
The wizard, consisting of four steps, guides you through the process on how you can 
import an ASCII file as follows: 

 
 Step 1 
 

- If the items in the ASCII file are separated by specific characters such as tab, 
semicolon, comma or spaces, select Free. 

- If the items, positioned in columns of fixed width are separated by spaces, select 
Position.  

 
• In the Start Import at Row  box, define the first row to be imported. (The first row of 

the ASCII file is selected by default.)  
• In the Stop Import at Row  box, define the last row to be imported. (The last row of 

the ASCII file is selected by default).  
• In the Keyword box, type an optional keyword. Only lines containing the keyword 

will be imported. A keyword may consist of one or more alphanumeric characters.   
• Click Next > to the next step of the ASCII File Import Wizard, < Back to the previous 

step.  
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Step 2 
 
If you have selected Free in the previous step: 
  
- Depending on the ASCII file you want to import, you can select one or more column 

separators. Possible separators are Tab, Semicolon, Comma and Space .  
 
- Select Other if the formers are not matching separators in the file and in the box, right of 

Other, type a separator.  
 
- Select Treat consecutive delimiters as one if consecutive delimiters are meant as 

one. 
  

If you have selected Position in the previous step:  
Column separators can be inserted, moved and deleted as follows: 
 
Insert 
Click the position in the data preview window where you want to insert the separator.  
 
Move  
Click a separator in the data preview header and move it to the new position.  
 
Delete  
In the data preview window, double-click the separator at the column border to delete.  
 
Click Next > to the next step of the ASCII File Import Wizard, < Back to the previous 
step.  
 
Note: 
 
The data preview window will show how the file contents are listed in columns. Ensure 
that every column contains the correct data before advancing to the next step.  
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Step 3 
 
All data are now presented in columns. A linear unit can be defined at this stage for the 
coordinate values. To get to the final step of data import, headers must be assigned to 
the columns. The order of the data within a line is not of importance. However, an Easting 
must co-exist with a Northing and vice versa.  

 
• In the Linear Units box, click either Meters or Feet (US).  

 
• Assign a header to each column you want to import.  

To assign a header, right-click the numbered column header in the data preview 
window and select the appropriate column header (Point Id, Easting, Northing, 
Elevation, Code or Attributes (1 – 8)) on the pop-up list.  
A header can be removed by selecting Remove on the pop-up list. All assigned 
headers will be removed when you select Remove All on the pop-up list.  

 
• Click Next > to the next step of the ASCII File Import Wizard, < Back to the previous 

step.  
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Note: 
 
Columns with no header assigned will not be imported.  

 
Step 4 

 
The current import mask can be stored to a template, which is used to import ASCII files 
to Coordinate Editor as follows: 
 
• In the Template Name box, type a name for the template.  
• Click Finish to import, < Back to the previous step.  
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Note: 
 
The defined template can be used to open other ASCII files of similar structure other than 
the file, which the template is created for. Defined templates can be selected in the 
Template box of the Open File dialog box.    

 
3.4.4 Coordinate Editing – Define Settings 
 
 You can define the Linear Unit and Precision of a coordinate file.  
 

1. On the Options menu, click Settings…. 
2. In the Linear Unit box, click either Meter or Feet(US). Depending on the Linear Unit 

selected, in the Precision box, click a precision.    
 

 
 

The available linear units and precision are as follows:  
 
 

Linear Units Precision 
Meter 0.001 

0.0001 
0.00001 

Feet (US) 0.001 
0.0001 

 
 
3.4.5 Coordinate Editing – Data Check 
 

You can check for invalid data within a coordinate file by clicking Check Data on the 
Options menu. Invalid data are mainly row(s) containing:  
  

• no Point Id,  
• Easting without Northing or   
• Northing without Easting.  
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3.4.6 Coordinate Editing – Columns Display 
 

You can hide/display one or more columns of a coordinate list with the followings: 
 
1. On the Options menu, click Columns…. 
2. In the Columns dialog box, select the column(s) you want to hide/display.   

 

 
 

 
3.5 Codelist Manager  
 

Codelist Manager enables you to create/modify Codelists that will work in Leica 
instruments. A Codelist may consist of Layers, Codes and Attributes , depending on the 
type of instruments used.  
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3.5.1 Create a new Codelist  
 

1. On the File menu, click New.  
2. Select an Instrument class and a Codelist type on the Codelist type dialog box. 
3. Click OK to see the New Codelist dialog box. 
4. Under General, type a name for the Codelist.  
5. Click OK to create.  

 

 
 

Codelist Types 
 
 TPS300 Series TPS700 Series 
Basic  Free Coding for WI 41 – 49 

 
The Basic Codelist consists of 
Codes, Attributes 1 – 8 with 
optional default value (Attribute 
Value), which can be defined for 
each code.   

Free Coding for WI 41 – 49 
 
The Basic Codelist consists of 
Codes, Attributes 1 – 8 with 
optional default value (Attribute 
Value), which can be defined for 
each code. 
 
An optional shortcut can be 
defined for each code, which is 
used for quick coding on TPS700 
Series instruments.     

Advanced In addition to the Basic Codelist, 
the following features are available 
in the Advanced Codelist: 
 
- definition of a Code description 
- editable Attribute Names 
- Attribute Type 
- Value Type  

In addition to the Basic Codelist, 
the following features are available 
in the Advanced Codelist: 
 
- definition of a Code description 
- editable Attribute Names 
- Attribute Type 
- Value Type  
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 TPS1100 Series 
Basic (GSI-8) Free Coding for WI 41 – 49. Coding with Code-Key. 

 
The Basic (GSI-8) Codelist consists of Codes, Descriptions, 
editable Attribute Names and Attribute Types with optional 
Default Values, which can be defined for each code.  
 
An optional shortcut can be defined for each code, which is 
used for quick coding on TPS1100 Series instruments.     

Basic (GSI-16) Free Coding for WI 41 – 49. Coding with Code-Key. 
 
The Basic (GSI-16) Codelist consists of Codes, Descriptions, 
editable Attribute Names and Attribute Types with optional 
Default Values, which can be defined for each code.  
 
An optional shortcut can be defined for each code, which is 
used for quick coding on TPS1100 Series instruments 

Advanced (GSI-8) Free Coding for WI 41 – 49. Coding with Code-Key. 
 
Point Codelist for WI 71 –79. 
 
In addition to the Basic Codelist, the following features are 
available in the Advanced Codelist: 
 
- Value Type (Text, Real, Integer) 
- Value Region (None, Choice-list, Range) 
- Attribute Values 

Advanced (GSI-16) Free Coding for WI 41 – 49. Coding with Code-Key. 
 
Point Codelist for WI 71 –79. 
 
In addition to the Basic Codelist, the following features are 
available in the Advanced Codelist: 
 
- Value Type (Text, Real, Integer) 
- Value Region (None, Choice-list, Range) 
- Attribute Values 
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3.5.2 Create a new Code 
 

1. With focus on the tree-view, click New > New Code on the Data menu.  
 

 
 

 
2. On the New Code dialog, under the Code column, type a name for the new Code. A 

Code name may consist of a maximum of 8 alphanumeric characters.    
3. Under the Short Cut column, type a short cut for the new Code. A Short Cut may 

consist of a maximum of 2 digits.  
4. Under the De scription column, type a description for the new Code. A Description 

may consist of a maximum of 16 alphanumeric characters.  
5. Under the Type column, click a Type (Free, Point , line or polygon). Note that the 

available options for Type depends on the type of Codelist you have selected.  
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6. Press the ENTER key to add the next Code.   
  

 
 
3.5.3 Create a new Attribute  
 

1. On the tree-view pane, with focus on the  of the Code you want to attach the new 
Attribute and click New > New Attribute… on the Data menu.  

2. In the New Attribute  dialog box, type a name for the Attribute in the Attribute Name 
box. An Attribute name can consist of a maximum of 30 alphanumeric characters. 

3. In the Attribute Type box, click Normal, Mandatory or Fixed. If Fixed is clicked, only 
the Default Value  will be displayed on the instrument screen-board and is also 
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automatically attached to the Attribute. If Mandatory is selected, the Value must be 
edited in the field.  

4. In the Value Type box, click Text, Real or Integer.  
5. In the Value Region box, click None, Choice List or Range. If Real or Integer  is 

clicked in the previous step, you can select None, Choice List or Range. If Text  is 
clicked, you have either to select None or Choice List.  
 
If either Choice List or Range is selected in the previous step, click the Attribute 
Values tab. The followings show how you can enter value(s) for the Value Region 
you have selected in the previous step:  
 
Choice List 
 
Click  
Add to enter a new value. 
Delete to delete a value.  
Move Up to move a Value one position up in the list. 
Move Down to move a Value one position down in the list. 
 
Range 

     
Enter the range of values in the From and To boxes.  

 
 
6. In the Default Value box, enter a value. You can define the Default Value from the 

Choice List or Range if you had selected either as the Value Region in step 5. Note 
that it is optional to enter a value in the Default Value box. For a Fixed Value, you 
have to define its Default Value.  

7. Click OK to create.  
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3.6 Software Upload 
 

Software Upload can either be used to transfer system software files from the PC to a 
TPS300/700 Series or DNA instrument or system firmware, system languages, EDM/ATR 
firmware, applications or configurations from the PC to a TPS1000 Series , TPS1100 
Series or RCS1100 instrument. 
 
The program also enables you to view general information, the system environments and 
installed applications of either a TPS1000 or TPS1100 Series connected instrument. 

 
3.6.1 Transfer software files 
 

To ensure a successful uploading of software files, the instrument must be connected to 
a serial port and switched off. The communications settings for the serial port of the PC 
must match the communications parameters set in the connected instrument.  
 
For the TPS300/700 Series & DNA instruments, you can transfer software files through 
its Transfer files from PC to sensor dialog box. For the TPS1000 & TPS 1100 Series 
and RCS1100 instruments, you will be guided by the Software Installation Wizard for the 
transferring of software files.   
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3.6.2 Transfer software files to TPS300/700 Series or DNA instruments   
 

1. On the Utilities menu, click Transfer files….  
2. In the Drives box, click the drive that contains the software files.  
3. In the Directories box, click the directory that contains the software files. 
4. In the Components box, click the components to be transferred to the connected 

instrument.  
5. Click Transfer to upload. 
  
 

 
 
Note: 
 
• Ensure that the instrument battery does not run out during the installation of the 

system firmware or EDM/ATR firmware. It is recommended that the battery be freshly 
charged before the start of a transfer. 

• Once the transfer of software files has been implemented, the transfer must not be 
cancelled and the instrument must not be disconnected.  
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3.6.3 Transfer software files to TPS1000/1100 or RCS1100 Series instruments 
 

A Software Installation Wizard, explained as follows, will guide you through the process 
on how you can transfer the software files. Depending on the software type you select, 
you will see the following dialogs:  

 
Software Installation Wizard - Select Software Type 

 
• On the Software Installation Wizard dialog, click System Firmware  or Other 

Sensor Software (System Language, EDM Firmware, ATR Firmware, Applications, 
Configuration) to install. 

• Click Next > to the next step of the Software Installation Wizard. 
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Software Installation Wizard - System Firmware  
 

• Click  on the right of the Select the directory of the System Firmware box to 
select the location of the software file you want to transfer.  

• On the Choose Directory dialog box, under Drive, click the directory that contains 
the software file you want to install.  

• In the list box above, select the appropriate folder.  
• Click OK to accept selected directory or Cancel to abort function.  

Note: You will return to the Software Installation - System Firmware dialog after 
clicking either OK or Cancel.    

• In the Select the System Firmware you want to install list box, select the software 
file you want to transfer. 

• Click Next > to the next step of the Software Installation Wizard, < Back to return 
to the previous step. 
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Software Installation Wizard - Other Sensor Software 
 
• On the Software Installation Wizard dialog, you can select one or more of the 

following components:  
 
System Language 
EDM Firmware  
ATR Firmware 
Applications  
Configuration (only applicable for TPS1100 Series instruments)  

 
• Click Next > to the next step of the Software Installation Wizard, < Back to return 

to the previous step. 
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Software Installation Wizard - System Language 
 

• Click  on the right of the Select the directory of the System Language box to 
select the location of the software file you want to transfer.  

• On the Choose Directory dialog box, under Drive, click the directory that contains 
the software file you want to install.  

• In the list box above, select the appropriate folder.  
• Click OK to accept selected directory or Cancel to abort function.  

Note: You will return to the System Language dialog after clicking either OK or 
Cancel.  

• Click  on the right of the Select your desired language. box to select the 
language of the software file you want to transfer.  

• In the Select the System Language you want to install. list box, select the 
software file you want to transfer. 

• Click Next > to the next step of the Software Installation Wizard, < Back to return 
to the previous step. 
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Software Installation Wizard - EDM Firmware  
 

• Click  on the right of the Select the directory of the EDM Firmware box to 
select the location of the software file you want to transfer.  

• On the Choose Directory dialog box, under Drive, click the directory that contains 
the software file you want to install.  

• In the list box above, select the appropriate folder.  
• Click OK to accept selected directory or Cancel to abort function.  

Note: You will return to the Software Installation - EDM Firmware dialog after 
clicking either OK or Cancel.  

• In the Select the EDM Firmware you want to install. list box, select the software 
file you want to transfer. 

• Click Next > to the next step of the Software Installation Wizard, < Back to return 
to the previous step. 
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Software Installation Wizard - ATR Firmware  
 

• Click  on the right of the Select the directory of the ATR Firmware box to 
select the location of the software file you want to transfer.  

• On the Choose Directory dialog box, under Drive, click the directory that contains 
the software file you want to install.  

• In the list box above, select the appropriate folder.  
• Click OK to accept selected directory or Cancel to abort function.  
• Note: You will return to the Software Installation - ATR Firmware dialog after 

clicking either OK or Cancel.  
• In the Select the ATR Firmware you want to install. list box, select the software file 

you want to transfer. 
• Click Next > to the next step of the Software Installation Wizard, < Back to return 

to the previous step. 
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Software Installation Wizard - Leica Applications 
 

• Click  on the right of the Select the directory of the Applications box to select 
the location of the software file you want to transfer.  

• On the Choose Directory dialog box, under Drive, click the directory that contains 
the software file you want to install.  

• In the list box above, select the appropriate folder.  
• Click OK to accept selected directory or Cancel to abort function.  

Note: You will return to the Software Installation - Leica Applications dialog after 
clicking either OK or Cancel.  

• Click  on the right of the Select your desired language. box to select the 
language of the software file you want to transfer.  

• In the Select the Applications you want to install and define the loading order. 
list box, select the software file(s) you want to transfer. 

• Click Next > to the next step of the Software Installation Wizard, < Back to return 
to the previous step. 
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Software Installation Wizard - Configuration 
 

• Click  on the right of the Select the directory of the Configuration box to select 
the location of the software file you want to transfer.  

• On the Choose Directory dialog box, under Drive, click the directory that contains 
the software file you want to install.  

• In the list box above, select the appropriate folder.  
• Click OK to accept selected directory or Cancel to abort function.  

Note: You will return to the Software Installation - Configuration dialog after 
clicking either OK or Cancel.  

• Click  on the right of the Select your desired language. box to select the 
language of the software file you want to transfer.  

• In the Select the Configuration you want to install. list box, select the software 
file(s) you want to transfer. 

• Click Next > to the next step of the Software Installation Wizard, < Back to return 
to the previous step. 
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Software Installation Wizard - Current selection   

 
• Click Finish to upload the software file(s) after you have confirmed your selection in 

the Current Selection list box, < Back to return to the previous step.     
 

 
 
 

 Please wait while the upload is in progress.  
 

 
 
 
 Finally, click OK on the Software Upload dialog to end the uploading procedures.  
 

 
 


